Antwort schreiben 
 
Themabewertung:
  • 1 Bewertungen - 5 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[geteilt] Probleme mit Kontaktformularen (was: Wieder was für die Datenbank ;))
09.03.2012, 07:12 (Dieser Beitrag wurde zuletzt bearbeitet: 10.03.2012 13:33 von Thomas Wagner.)
Beitrag #1
[geteilt] Probleme mit Kontaktformularen (was: Wieder was für die Datenbank ;))
Anmerkung der Moderation: Fortsetzung dieses Threads

Klingt gut und bin ich dafür Smile
Aber noch eine andere Frage, wenn sie gestattet ist.

Bei dem Formular steht 2x der Urheber drin, einmal für das Original und einmal für die Coverversion. Ich hab bei meinem ersten Beitrag, bei der Coverversion Urheber: "Unbekannt" hingeschrieben, da ich nur den Urheber vom Original kenne. Ist das korrekt so oder muss ich erst noch weitere Recherchen machen?
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
09.03.2012, 07:28
Beitrag #2
RE: Wieder was für die Datenbank ;)
Noch kleine Anmerkung. in der Datenbank lässt sich irgendwie kein Jahr eintragen. Das Feld dafür, ist nicht anklickbar.

PS, wollte meinen Beitrag hier editieren, aber ich war langsamer als 15 Minuten^^
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
09.03.2012, 13:23
Beitrag #3
RE: Wieder was für die Datenbank ;)
(09.03.2012 07:12)Deejay2302 schrieb:  Bei dem Formular steht 2x der Urheber drin, einmal für das Original und einmal für die Coverversion. Ich hab bei meinem ersten Beitrag, bei der Coverversion Urheber: "Unbekannt" hingeschrieben, da ich nur den Urheber vom Original kenne. Ist das korrekt so oder muss ich erst noch weitere Recherchen machen?
Das kannst du frei lassen. Wenn du aber eine Quelle vor dir hast (insbesondere die Platte), in der die Urheberangaben stehen, dann gib die Urheber und die Quelle bitte an. Das wäre dann sehr hilfreich für uns.

Zitat:Noch kleine Anmerkung. in der Datenbank lässt sich irgendwie kein Jahr eintragen. Das Feld dafür, ist nicht anklickbar.
Falls du das Problem meinst, dass die Jahreszahlfelder durch ein Werbebanner verdeckt werden, so kam das Problem beim Browser Firefox plötzlich von einer Version zur nächsten auf, ohne dass wir am Quellcode der Website irgendwas geändert hätten. Vermutlich liegt das also am Browser. Leider hat sich bis jetzt noch niemand gefunden, der die Website an dieser Stelle Firefox-tauglich umprogrammiert, weil wir gerade primär versuchen, unsere Datenbanksoftware neu zu schreiben.

Abhilfe: Entweder einen anderen Browser (z. B. Internet Explorer) benutzen oder Javascript deaktivieren.

Thomas Wagner
coverinfo.de-Redaktion
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.03.2012, 04:12
Beitrag #4
RE: Wieder was für die Datenbank ;)
(09.03.2012 13:23)Thomas Wagner schrieb:  Falls du das Problem meinst, dass die Jahreszahlfelder durch ein Werbebanner verdeckt werden, so kam das Problem beim Browser Firefox plötzlich von einer Version zur nächsten auf, ohne dass wir am Quellcode der Website irgendwas geändert hätten. Vermutlich liegt das also am Browser.

Abhilfe: Entweder einen anderen Browser (z. B. Internet Explorer) benutzen oder Javascript deaktivieren.

Also Werbebanner habe ich keine gesehen, da ich einen Werbeblocker verwende. Werd ich mal in Betracht ziehen, anderen Browser zu nutzen. Gibt ja ne Menge portable Browser Big Grin
Kann mich ja mal mit umhören, wer Ahnung von sowas hat. Ich kenn mich mit HTML/PHP nur bedingt aus, solange das fertige Script schon vorliegt, kann ich es auch soweit ändern. Aber Java?! Rolleyes

Ich nehme mal an das ihr speziell jemanden für´s Java Coding sucht?
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
10.03.2012, 13:29
Beitrag #5
Probleme mit Kontaktformularen (Jahreszahlfelder)
(10.03.2012 04:12)Deejay2302 schrieb:  Also Werbebanner habe ich keine gesehen, da ich einen Werbeblocker verwende. Werd ich mal in Betracht ziehen, anderen Browser zu nutzen. Gibt ja ne Menge portable Browser Big Grin

Ich benutze natürlich unsere eigenen Formulare so selten. :-) Das Deaktivieren von JavaScript führt bei mir i. d. R. dazu, dass das Werbebanner nicht zu sehen ist. Aber ich habe gerade festgestellt, dass ich dann trotzdem das Jahreszahlfeld nicht anklicken kann, sondern zu der beworbenen Website komme. War mir vorher gar nicht bewusst. Bei dir ist es vermutlich wegen des Werbeblockers so, dass du nicht zu der anderen Website umgeleitet wirst.

Was bei mir aber funktioniert, ist den Cursor in ein anderes Feld (z. B. Titel) zu platzieren und dann die Tabulatortaste zu drücken, um zum Jahreszahlfeld zu kommen. Vielleicht klappt das bei dir auch.

Zitat:Kann mich ja mal mit umhören, wer Ahnung von sowas hat. Ich kenn mich mit HTML/PHP nur bedingt aus, solange das fertige Script schon vorliegt, kann ich es auch soweit ändern.

Gerne, wir können immer noch Leute gebrauchen, die an coverinfo.de programmieren möchten. Unsere Redakteure bringen das Projekt nämlich nur inhaltlich voran; es wäre sehr schön, wenn genügend Leute es auch technisch unterstützen würden.

Zitat: Aber Java?! Rolleyes

Ich nehme mal an das ihr speziell jemanden für´s Java Coding sucht?

JavaScript hat mit Java nichts zu tun. Mit Java arbeiten wir nicht. Aber es gibt schon mal das eine oder andere JavaScript auf unserer Website, z. B. um die E-Mail-Adressen vor den Spamrobots zu verstecken.

Thomas Wagner
coverinfo.de-Redaktion
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
12.03.2012, 16:32
Beitrag #6
RE: Probleme mit Kontaktformularen (Jahreszahlfelder)
(10.03.2012 13:29)Thomas Wagner schrieb:  Was bei mir aber funktioniert, ist den Cursor in ein anderes Feld (z. B. Titel) zu platzieren und dann die Tabulatortaste zu drücken, um zum Jahreszahlfeld zu kommen. Vielleicht klappt das bei dir auch.

Funktioniert bei mir auch. Hätte ich auch selber darauf kommen können^^

(10.03.2012 13:29)Thomas Wagner schrieb:  Gerne, wir können immer noch Leute gebrauchen, die an coverinfo.de programmieren möchten. Unsere Redakteure bringen das Projekt nämlich nur inhaltlich voran; es wäre sehr schön, wenn genügend Leute es auch technisch unterstützen würden.

Hatte ich mir fast gedacht, nachdem euer Coder das zeitliche gesegnet hatte :-/

(10.03.2012 13:29)Thomas Wagner schrieb:  JavaScript hat mit Java nichts zu tun. Mit Java arbeiten wir nicht. Aber es gibt schon mal das eine oder andere JavaScript auf unserer Website, z. B. um die E-Mail-Adressen vor den Spamrobots zu verstecken.

Weiss ich doch Wink
Ich glaube auch zu wissen wo der Fehler bei dem Werbebanner liegen könnte. habe mir mal den Quelltext dazu angeschaut.
Das Problem liegt, schätze ich in der Style CSS. Speziell bei dem Attribut "valign="middle"

<td width="160" height="19" align="center" valign="middle"

Dort sollte man testhalber ändern zu: valign="right" dann sollte die Werbebox (table) rechtsbündig sein. Die Zeile die ihr suchen müsst in der CSS beginnt mit: <div id="banner1">

Kann ich natürlich nicht genau sagen ohne es selber testen zu können. Wink Am besten testen. Und vorher Backup machen Wink
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
15.03.2012, 03:17
Beitrag #7
RE: [geteilt] Probleme mit Kontaktformularen (was: Wieder was für die Datenbank ;))
Danke für deine Hilfe!
Aber ich kann dieses
PHP-Code:
valign="middle" 
überhaupt nicht im Quellcode finden. (Vielleicht stammte das aus dem Code eines bestimmten Werbebanners?) In welcher Datei hast du das denn gefunden? Am besten gibst du mir mal den genauen URL an.

Thomas Wagner
coverinfo.de-Redaktion
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
16.03.2012, 19:54
Beitrag #8
RE: [geteilt] Probleme mit Kontaktformularen (was: Wieder was für die Datenbank ;))
(15.03.2012 03:17)Thomas Wagner schrieb:  Danke für deine Hilfe!
Aber ich kann dieses valign="middle" überhaupt nicht im Quellcode finden. (Vielleicht stammte das aus dem Code eines bestimmten Werbebanners?) In welcher Datei hast du das denn gefunden? Am besten gibst du mir mal den genauen URL an.

Dem Tip, valign="middle" durch valign="right" zu ersetzen, sollte man nicht folgen. valign steht für "vertical alignment", und das kann man nicht sinnvoll auf "right" setzen. Zulässig sind da nur die Optionen "top", "bottom" und eben "middle". Der Wert "right" wäre nur für das align-Attribut erlaubt, neben "left" und "center". Einzelheiten dazu gibt's hier: Selfhtml.org - Attribute des td-Tags.
Ob jetzt aber ein align="right" an dieser Stelle richtiger als align="center" wäre, kann ich im Augenblick nicht beurteilen.

Ich kann nämlich ebenfalls die genannte Zeile in der ganzen Seite des Eintragsformulars nicht finden. Die Zeichenkette "banner1" genausowenig. Außerdem habe ich das Eintragsformular gerade mal im Firefox 10 geöffnet - ohne Script- und Werbeblocker natürlich - und ich kann da kein Problem mit nicht anklickbaren Jahreszahlfeldern entdecken. Ich sehe zwei Mögllichkeiten: Entweder ist das Problem mit einer neueren Firefox-Version wieder verschwunden oder es tritt nur bei einem ganz bestimmten Werbebanner auf...

Im übrigen können die ganzen angegebenen Auszüge aus dem Seitencode nicht aus einer CSS-Datei stammen, da sie alle reines HTML sind, das mit CSS nicht gleichzusetzen ist. Ist hier also eventuell irgendeine .php- oder .html-Datei gemeint?

Alexander Glintschert
coverinfo.de-Redaktion
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.03.2012, 00:19
Beitrag #9
RE: [geteilt] Probleme mit Kontaktformularen (was: Wieder was für die Datenbank ;))
Hallo, Alexander!

Danke für deinen Hinweis.

Ich benutze Firefox 10.0.2 unter Windows 7 und das Problem besteht definitiv noch. (Und gerade wird mir ein Update auf Firefox 11 angeboten.) Vielleicht hängt es auch mit dem Betriebssystem zusammen. Es ist nicht nur Werbung vor den Jahreszahlfeldern, sondern die einzelnen Felder an sich sind auch verschoben.

Thomas Wagner
coverinfo.de-Redaktion
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
17.03.2012, 18:17
Beitrag #10
RE: [geteilt] Probleme mit Kontaktformularen (was: Wieder was für die Datenbank ;))
Das ist zumindest mal merkwürdig. Ich habe den Test jetzt noch mal wiederholt und die Add-Ons nicht nur deaktiviert, sondern deinstalliert. Somit habe ich jetzt einen ganz normalen Firefox 10 ohne jegliches Add-On oder sonstwas verwendet. Auf Windows Vista.
Ergebnis: Die Werbung bleibt schön brav neben dem Formular und behindert es in keiner Weise. Ich kann alle Felder direkt anklicken und auch was eingeben.
Damit habe ich erstmal leider keine Idee, wo die Ursache für das Problem liegen könnte. Sad

Alexander Glintschert
coverinfo.de-Redaktion
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren
Antwort schreiben 


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste

Impressum | Forumregeln | coverinfo.de | Nach oben | Zum Inhalt | Archiv-Modus | RSS-Synchronisation